Hello from Second Life

Start your first thread and say Helllllllooooooo.

Hello from Second Life

Postby AIML » April 10th, 2015, 8:19 pm

Hi, I'm from the Netherlands and connected Program O to an object in Second Life.
At the moment the chat-bot has incarnated into a small wyvern (dragon) sitting on my shoulder.
She, Alice Wyvern, mingles with everybody within 20 meters and is fun to watch.

In some rare cases she is addressing to SL usernames, but more often she just calls them "friend".
I do send the unique SL user key along with the request as convo_id, so the conversations will be grouped.
The XML response however returns an incremental user_id and is not very useable to personalize the response.

Anybody have solved this communication thing? Or maybe found some hidden query strings to be used within Second Life?
AIML
Casual Member
 
Posts: 1
Joined: April 10th, 2015, 7:48 pm

Re: Hello from Second Life

Postby GeekCaveCreations » April 11th, 2015, 5:38 pm

Hi and welcome! :)

It sounds like you're experiencing a bug with the XML interface. Can you take a look in the logs folder and see if the error log contains any information that might be relevant? Also, it might prove useful to configure Program O to output debug files (if it isn't already configured to do so), and post an example file here that involves a conversation where the chatbot calls someone "friend" when it wasn't supposed to.
Comforting the disturbed, and disturbing the comfortable
Chat with Morti
User avatar
GeekCaveCreations
Safe, Reliable Insanity, Since 1961
 
Posts: 1115
Joined: April 18th, 2011, 10:52 pm
Location: Nevada, USA


Return to Introduce Yourself

Who is online

Users browsing this forum: No registered users and 1 guest

cron